Firebaseのバージョンを7.1.0->8.1.0にアップデートしたら下記エラー発生。

E/Unity: AndroidJavaException: java.lang.NoClassDefFoundError: Failed resolution of: Lcom/google/firebase/iid/FirebaseInstanceId;

原因:Firebae8.1.0では「Firebase Instance ID」が必要になった模様。
対応:公式より「Firebase Instance ID」をダウンロードし、インストール。

対応後ビルドOK。